Submissions to our admin tool are failing
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted Feb 04, 2020 - 18:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2020 - 17:35 UTC
Investigating
We're investigating an incident with our admin tool (doi.crossref.org). Since our release from earlier today, it appears that users are receiving this error message - "Incorrect password for username: refquery" - when attempting to make submissions.
Posted Feb 04, 2020 - 16:48 UTC
This incident affected: Content Registration (Admin tool) and Beta (Metadata Manager).