From 05:46 UTC on 17 April we experienced a sustained surge of traffic to our website, which was caused by bot activity distributed across multiple IP addresses. The service recovered automatically without intervention after about an hour, and we have since applied tighter rate-limiting to the source. We are also reviewing options to further improve the scalability and resilience of the service going forward.
Posted Apr 17, 2026 - 10:23 UTC
Monitoring
The website is available again. We are monitoring the situation.
Posted Apr 17, 2026 - 07:04 UTC
Investigating
The main Crossref website (www.crossref.org) has been down since 05:46 UTC. We are investigating the cause of the issue.