Performance issues with Participation Reports

Incident Report for Crossref

Resolved

This incident has been resolved. -IF
Posted Aug 27, 2025 - 13:16 UTC

Update

A fix has been implemented. We will be monitoring the results for a few days before we resolve this incident. -IF
Posted Aug 25, 2025 - 13:24 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 20, 2025 - 12:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 19, 2025 - 19:45 UTC

Identified

The issue has been identified and a fix is being implemented. >EA
Posted Aug 19, 2025 - 13:56 UTC

Investigating

We have noted performance-related issues with Participation Reports. We are investigating the underlying cause. >EA
Posted Aug 19, 2025 - 09:39 UTC
This incident affected: Sites (Participation reports).