Email confirmations not being delivered for test deposit system
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted Dec 16, 2019 - 16:19 UTC
Update
We are continuing to investigate this issue.
Posted Dec 06, 2019 - 19:11 UTC
Investigating
Email confirmations from our test deposit system (test.crossref.org) are not currently being delivered for all users. We're investigating what is causing some users to not receive the notifications.
Posted Dec 06, 2019 - 19:11 UTC
This incident affected: Content Registration (Test admin tool).