Some indexing of metadata failing at the REST API (starting 8 July and continuing today)

Incident Report for Crossref

Resolved

This incident has been resolved. If you are still finding DOIs that have not been indexed in the REST API from July or August 2025 do let our technical support team know at support@crossref.org. - IF
Posted Aug 27, 2025 - 12:06 UTC

Monitoring

A fix has been implemented. We will be monitoring the results for a few days before we resolve this incident. -IF
Posted Aug 25, 2025 - 13:23 UTC

Update

We are continuing to work on a fix for this issue. Yesterday Panos on our technical team successfully re-pushed over 700,000 records that were registered in the previous week. So, all records registered up to 2025-August-21 T11:00:00 UTC should now be present in the REST API. - IF
Posted Aug 22, 2025 - 17:35 UTC

Update

We are continuing to work on a fix for this issue. Martyn Rittman, Crossref Program Lead, has provided additional details about the ongoing issues in our Community Forum: https://community.crossref.org/t/whats-going-on-with-the-rest-api-indexing-issues/14341 - IF
Posted Aug 20, 2025 - 17:47 UTC

Update

Our support and technical teams are finding a very small percentage of DOIs from our reindexing on 4 and 14 August that are not yet appearing in the REST API. If you have examples of DOIs that are not appearing in our REST API from registrations in July or August 2025, please do contact our support team - support@crossref.org - in order for us to investigate further. Our technical team continues to actively work on a fix. -IF
Posted Aug 18, 2025 - 14:15 UTC

Update

Our technical team completed the reindex of all records registered between 3 and 14 August earlier today. There is still an underlying issue that is causing some records to go unindexed in the REST API. We continue to investigate that cause. We will continue to push records that are not being indexed in the REST API until we find and fix the bug. -IF
Posted Aug 15, 2025 - 21:38 UTC

Update

Our technical team is reindexing all records registered between 3 and 14 August, because we found works missing in our REST API. That reindex should be completed by end of day tomorrow. We continue to investigate the underlying cause of these indexing errors. -IF
Posted Aug 14, 2025 - 19:19 UTC

Update

We continue to receive reports from members and metadata users of records missing from our REST API. For the records not being indexed, which we have confirmed has continued for records registered into August, this can cause downstream issues for a number of services (e.g., Crossref metadata search - search.crossref.org, Participation Reports, ORCID auto-update, and for external services that make use of the metadata in our REST API). Our technical team continues to work on a fix. -IF
Posted Aug 13, 2025 - 19:26 UTC

Identified

Unfortunately, we have found that this bug is impacting REST API indexing of DOIs registered in August, so the underlying issue that is causing a small percentage of DOIs from being indexed in the REST API persists. Our technical team continues to work on a fix. -IF
Posted Aug 11, 2025 - 18:14 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 06, 2025 - 18:21 UTC

Update

We have now reindexed all records since 7 July. No records were indexed from 17 to 19 July, but those records have all been reindexed in the last few days. There should be no missing records in the REST API for the month of July. We will continue to monitor this issue for the first couple of weeks of August to be sure that there are no other indexing issues with the REST API. -IF
Posted Aug 04, 2025 - 13:21 UTC

Monitoring

We’ve now solved the issues that were blocking reindexing. We will continue to monitor those issues, and will be working on adding the missing records that were not indexed earlier in July over the next couple of days. -IF
Posted Jul 30, 2025 - 19:20 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 30, 2025 - 16:03 UTC

Update

We have found that this bug is impacting REST API indexing of DOIs since 8 July. We have found examples of a minority of records missing from the REST API since that 8 July date. Our technical team continues to work on a fix. -IF
Posted Jul 28, 2025 - 18:46 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 25, 2025 - 20:41 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 23, 2025 - 20:20 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 22, 2025 - 19:37 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 22, 2025 - 13:23 UTC

Investigating

We have found that some records failed to be indexed by the REST API on 8 July and then again from 16 to 20 July. We believe this is related to our recent data centre migration (https://status.crossref.org/incidents/s92nm4xn1w84). Our technical team is investigating. -IF
Posted Jul 21, 2025 - 12:45 UTC
This incident affected: APIs (Public REST API, Polite REST API) and Metadata Plus (Plus REST API).