Email notifications from the deposit admin tool - doi.crossref.org - delivery delayed
Incident Report for Crossref
Resolved
We have resolved this incident. Email notifications have caught up and are now being sent for all new submissions. We're working on preventing the loss of expired email notifications in the future, but email notifications that expired as a result of our previous incident - https://status.crossref.org/incidents/d78f9ycfw07m - before being sent were lost. For those of you with missing email notifications, you may view past submissions within the admin tool by following these instructions: https://www.crossref.org/education/content-registration/verify-your-registration/submission-queue-and-log/#00143
Posted May 04, 2020 - 21:14 UTC
Investigating
We are currently investigating the delayed delivery of email notifications from doi.crossref.org and believe it is related to last week's issue: https://status.crossref.org/incidents/d78f9ycfw07m
Posted May 04, 2020 - 13:35 UTC
This incident affected: Content Registration (Admin tool).